Shop Floor Talk  

Go Back   Shop Floor Talk > Welding and Metalworking Forums > Welding

SFT Search:   
Reply
 
Thread Tools Display Modes
  #1  
Old 03-29-2020, 07:30 AM
OZWELDER's Avatar
OZWELDER OZWELDER is offline
Senior Member
 
Join Date: Mar 2007
Location: Mackay, Queensland.Australia
Posts: 655
Default Intermittent start of Miller Elite digital screen

Hi guys,
I have Miller Elite with an an annoying problem.
One day it will switch on and work and a few days later will not switch on after repeated tries.

Again a few days later it will turn on and the a bit later will not work and so on it goes.

Is this a known Miller Elite shield problem or a common defect?

No I don't know the model or how to indentify the model,but will give a description the insert measures 5 3/16" x 4 1/2"

The control panel is 4 1/4" x 1 1/4" and from the left side is the membrane (as all the buttons are) circular ON button with a rectangular MODE button to the right of that.

Modes available are weld/cutting /grind.

On the right side of the digital screen the are six arrow type buttons for the up and down -shade- sensitivity- and delay, all variable values.

It has had the correct (thickness) Button batteries replaced - the old ones tested the same voltage as the new ones.Contact for batteries inspected and all found to be good.

I am almost to the point of splitting the insert case and inspecting the circuit joints under and magnifying light for cold solder joints.

Are there any suggestions members can offer me as how I may fix the shield?

Thanks
Oz
__________________
Ozwelder
May your chooks turn into Emus and kick ya dunny down.
Reply With Quote
  #2  
Old 03-29-2020, 10:48 AM
greywynd's Avatar
greywynd greywynd is offline
I can dig it
 
Join Date: Dec 2005
Location: Wainwright, Alberta
Posts: 5,154
Default

No real suggestions, have one with issues though, will no longer turn on at all. So, following to see what you find out.


Sent from my iPhone using ShopFloorTalk mobile app
Reply With Quote
  #3  
Old 03-29-2020, 11:44 AM
Ironman's Avatar
Ironman Ironman is offline
Iron Modification Investigator
 
Join Date: Feb 2008
Location: Warburg, Alberta, Canada
Posts: 14,666
Default

Quote:
Originally Posted by OZWELDER View Post
Hi guys,
I have Miller Elite with an an annoying problem.

Are there any suggestions members can offer me as how I may fix the shield?

Thanks
Oz
Has this got wet or been in the rain at any time?
They all use the same electronics, and I have killed one, not Miller brand, but they are the same under the plastic. It was just a little rain and I shook off the water, but it was dead.
No, I could not fix it, replaced.

FWIW, I left a Milwaukee impact out in the wet and it died on first use the next day, the repair shop said it got wet.
__________________
Gerry
You got freedom of speech, if you don't say too much.
Aaron Neville.

The virtue is always a cover for the sin. That's the key to understanding the modern left. Whatever they're accusing you of doing, they are doing themselves but more enthusiastically. And that's definitely the story of Justin Trudeau. Tucker Carlson
Reply With Quote
  #4  
Old 03-29-2020, 11:56 PM
OZWELDER's Avatar
OZWELDER OZWELDER is offline
Senior Member
 
Join Date: Mar 2007
Location: Mackay, Queensland.Australia
Posts: 655
Default

Quote:
Originally Posted by Ironman View Post
Has this got wet or been in the rain at any time?
They all use the same electronics, and I have killed one, not Miller brand, but they are the same under the plastic. It was just a little rain and I shook off the water, but it was dead.
No, I could not fix it, replaced.

FWIW, I left a Milwaukee impact out in the wet and it died on first use the next day, the repair shop said it got wet.
Hi Ironman,

The very opposite,the shield has been looked after all its life.It came with a drawstring bag a gets hung in that in the shed in the shade.

It was working fine the day before yesterday but I got it down and press the blue blazes out of the membrane and got nothing. in another few days if it follows the plan,it will work.

I will wait a few days to see if anything else comes up and open it and inspect it. I shall be looking for a cold solder joint.

In its day it was expensive shield like 350 odd dollars.

Thanks for the replies.

Oz
__________________
Ozwelder
May your chooks turn into Emus and kick ya dunny down.
Reply With Quote
  #5  
Old 03-30-2020, 01:15 AM
OZWELDER's Avatar
OZWELDER OZWELDER is offline
Senior Member
 
Join Date: Mar 2007
Location: Mackay, Queensland.Australia
Posts: 655
Default

Hi Guys,
Its and hour and something later than my last post.

I have just been playing with the module and decided to shine my bright Cree type led torch in to the light receiver/trigger? cells across the bottom.

Well sort of, set the torch ( flashlight to you,I think) on its end and held/ balance the cells over the end of the torch.

Ten seconds of light and press button and yes the bloody digital screen operated.

Woohoo

I am no electronic genius but there will be a way to diagnose this in a step by step manner.
Any thoughts on the way to go?

Oz
__________________
Ozwelder
May your chooks turn into Emus and kick ya dunny down.
Reply With Quote
  #6  
Old 03-30-2020, 01:27 AM
mccutter's Avatar
mccutter mccutter is offline
Post Fiend
 
Join Date: Mar 2006
Location: Central Florida
Posts: 9,000
Default

Quote:
Originally Posted by OZWELDER View Post
I am no electronic genius but there will be a way to diagnose this in a step by step manner.
Any thoughts on the way to go?
There are probably capacitors attached to the photocells that add a little "boost" to help the photocells work. I've had non-battery hoods that needed a "refresh" under a light source before putting into use so they would function properly. Maybe this is the workaround you need to do before use?
__________________

TA Arcmaster 185 w/tig/stick kit
MillerMatic 252 w/3rd gen 30A
MM140 w/o AS, w/CO2
Hobart (Miller) 625 plasma
Hobart 250ci plasma
Victor O/A (always ready, but bored)
Lincoln Patriot autodark (freebie)
45ACP Black Talons for those stubborn jobs...
Reply With Quote
  #7  
Old 03-30-2020, 08:02 AM
Ironman's Avatar
Ironman Ironman is offline
Iron Modification Investigator
 
Join Date: Feb 2008
Location: Warburg, Alberta, Canada
Posts: 14,666
Default

Quote:
Originally Posted by OZWELDER View Post
Hi Guys,
Its and hour and something later than my last post.

I have just been playing with the module and decided to shine my bright Cree type led torch in to the light receiver/trigger? cells across the bottom.

Well sort of, set the torch ( flashlight to you,I think) on its end and held/ balance the cells over the end of the torch.

Ten seconds of light and press button and yes the bloody digital screen operated.

Woohoo

I am no electronic genius but there will be a way to diagnose this in a step by step manner.
Any thoughts on the way to go?

Oz
If you do get into the guts of it, check that the photocells are functioning properly and are clean of smoke.
__________________
Gerry
You got freedom of speech, if you don't say too much.
Aaron Neville.

The virtue is always a cover for the sin. That's the key to understanding the modern left. Whatever they're accusing you of doing, they are doing themselves but more enthusiastically. And that's definitely the story of Justin Trudeau. Tucker Carlson
Reply With Quote
  #8  
Old 03-30-2020, 11:41 AM
Norm W's Avatar
Norm W Norm W is offline
Elite Member
 
Join Date: May 2006
Location: Syracuse, NY
Posts: 2,840
Default

I have a HF hood that has been working for about 12 years. I hang it in the window so it gets a daily ration of sun light. If it's stupid but it works, it ain't stupid.
__________________
Make over, make do, or do without

Why do I have to press one for English when you're just gonna transfer me to someone I can't understand anyway?

Grant me the strength to accept the things I cannot change, the courage to change the things I can & the friends to post my bail when I finally snap!
Reply With Quote
  #9  
Old 03-30-2020, 01:02 PM
LKeithR's Avatar
LKeithR LKeithR is offline
Hey...wait...is there a prize?
 
Join Date: Aug 2011
Location: Langley, B.C.
Posts: 5,223
Default

Quote:
Originally Posted by OZWELDER View Post
...The very opposite,the shield has been looked after all its life.It came with a drawstring bag a gets hung in that in the shed in the shade...
Quote:
Originally Posted by OZWELDER View Post
...I have just been playing with the module and decided to shine my bright Cree type led torch in to the light receiver/trigger? cells across the bottom.

Well sort of, set the torch ( flashlight to you,I think) on its end and held/ balance the cells over the end of the torch.

Ten seconds of light and press button and yes the bloody digital screen operated...
That might just be the source of your problem. If the helmet is always kept in the dark it might need a boost to get it going. Try hanging it someplace where it gets light all the time and see if the problem goes away...
__________________
Keith

Measure twice and cut once...or...wait, was that the other way around?
Reply With Quote
  #10  
Old 03-31-2020, 10:43 AM
moe1942's Avatar
moe1942 moe1942 is offline
Voice of Experience
 
Join Date: Jun 2004
Location: Alexandria, Louisiana
Posts: 11,045
Default

I have the same hood and it needs light to work..When I kept it in the dark it wouldn't work. It works best when used every day...
__________________
Don't pick a fight with an old man. If he is too old to fight, he'll just kill you... John Steinbeck

"If we ever forget that we're one nation under God, then we will
be a nation gone under". ~Ronald Reagan

We should have picked our own cotton...

I love my women hot and my beer ice cold..
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Web Search:

All times are GMT -5. The time now is 12:24 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.