Shop Floor Talk  

Go Back   Shop Floor Talk > Welding and Metalworking Forums > Fabrication

SFT Search:   
Reply
 
Thread Tools Display Modes
  #31  
Old 08-15-2019, 09:21 AM
Steeveedee Steeveedee is offline
Member
 
Join Date: Nov 2012
Location: California
Posts: 113
Default

Quote:
Originally Posted by MetalWolf View Post
If I'm not mistaken that's an older early model engine. The running temp should be 180 and with the AC running it's going to raise the temp some up to around 195 So that seems pretty normal in the temperature range...
Now if your hitting temps of 200 to 230 then there might be some concerns there.
Agreed. Before I did these upgrades the truck would run up to 260ยบ at idle even with the severe duty fan clutch. Multiple things wrong with the setup. That the fan was too far into the shroud was probably the top problem, since it never coupled right for air flow. The 20" fan helped quite a bit, even without the shroud. I checked the cooling system for combustion byproducts, that was OK. But while doing it, I noticed that there wasn't much water flow. That's when I drilled 3 holes in the thermostat base. That helped even more, so I got a high-flow thermostat, as mentioned by noblng. That was the final piece of the puzzle. I can go put gas in it, and sitting idling at a light after that the temperature drops after going up with heat soak during the time it sat putting gas in it. It used to just keep climbing until I was rolling again.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Web Search:

All times are GMT -5. The time now is 12:11 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.